Перейти к содержимому

Свернуть чат ЧАТ Открыть чат во всплывающем окне

Ankuls : (28 September 2019 - 18:35 18) Nikolai4, я нет
Nikolai4 : (28 September 2019 - 08:03 08) DSO150 кто пользовался?
Ankuls : (27 September 2019 - 20:38 20) все занят
BOOST : (21 September 2019 - 22:44 22) Чому так глухо?
Ankuls : (20 September 2019 - 20:30 20) Ауууу

Фотография

Напряжение, ток, температура - индикация для блока питания


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 52

#41
rotaru

rotaru

    Пользователь

  • Проверенные
  • PipPip
  • 16 сообщений
Плату я немного изменил которая от пользователя al19. Собирал на травлёной плате а не на макетной. Что у меня получилось можно посмотреть в прикреплённом файле.
Да и дисплей я использовал WH1602D фирмы WINSTAR

Прикрепленные файлы

  • Прикрепленный файл  _AVR.lay   199.36К   74 Количество загрузок:


#42
zaa-1978

zaa-1978

    Продвинутый пользователь

  • Мастера
  • PipPipPip
  • 255 сообщений
  • ГородХарьков
rotaru, а чтонибудь с фьюзами делал?

#43
rotaru

rotaru

    Пользователь

  • Проверенные
  • PipPip
  • 16 сообщений
Нет. Это первая моя АVR.

Добавлено (27.04.2011, 19:27)
---------------------------------------------
Смотрел Datacheet на 79L05 - оказывается у неё вывод 1-END; 2- V in; 3-V out.
78L05- 1-й вывод - V out ; 2 - END; 3 - V in. Так что будьте внимательны.


#44
rotaru

rotaru

    Пользователь

  • Проверенные
  • PipPip
  • 16 сообщений
Вопрос. Возможно ми запитать LM358 по этой схеме.
Блок питания у меня без среднего вывода. Если у когото есть лучший вариант, буду благодарен за предложения.

Прикрепленные файлы

  • Прикрепленный файл  s5127366.gif   8.58К   58 Количество загрузок:


#45
zaa-1978

zaa-1978

    Продвинутый пользователь

  • Мастера
  • PipPipPip
  • 255 сообщений
  • ГородХарьков
rotaru, должно работать! только с1 и с2 по 1000мкф! а кренки возьми в то-92 корпусе 7805 и 7905 соответственно!

#46
zaa-1978

zaa-1978

    Продвинутый пользователь

  • Мастера
  • PipPipPip
  • 255 сообщений
  • ГородХарьков
для тек кто по какой то причине непонял фьюзи!

Прикрепленные файлы

  • Прикрепленный файл  s8615753.jpg   22.04К   66 Количество загрузок:


#47
rotaru

rotaru

    Пользователь

  • Проверенные
  • PipPip
  • 16 сообщений
Ребята. А что это за вывод LED на ЖК индикаторе (который с 17 вывода МК ), питание подсветки...?

#48
Nikolai4

Nikolai4

    Создатель

  • Администраторы
  • 1211 сообщений
да, это питание подсветки

#49
rotaru

rotaru

    Пользователь

  • Проверенные
  • PipPip
  • 16 сообщений
А 78L05 выдержит по току запитать и МК и подсветку в ТО-92?

#50
Warlock

Warlock

    Новичок

  • Проверенные
  • Pip
  • 2 сообщений
привет всем!

решил собрать этот индикатор. у кого то есть печатка пользователя al19 в .lay??
выложите пожалуйста

#51
Aleefi

Aleefi

    Новичок

  • Проверенные
  • Pip
  • 6 сообщений
Добрый день, господа!
Расшевелим немного темку.
Давно хотел сделать себе моддинг на Меге 8, но думал сделать на LED-сегментах. Эту статью увидел - понравилась. К тому же она чуток многофункциональнее...
В погоне за миниатюризацией сделал по схеме нашего украинского коллеги, в TQFP корпусе.
Получилось маленькое и приятное. Т.к. на SMD детали только перехожу - получилось немного коряво, да и глаза чуть не сломал...
Представляю на суд всевышним, т.е. Вам:
Изображение

Так выглядит в пропорции с экраном...
Изображение
Изображение

Схема заработала, в принципе, сразу. Прошивка досталась с ругательством вначале, другой скачать не удалось.
По печатке Dmitromakar1 спалил сначала обратный стабилизатор (LM79m05), потом, когда глянул в даташит, пришлось резать ножки на плате. Разводка была с ошибкой!
Не понял необходимость обратного питания на операционнике. Работает и от нуля. Прокомментируйте, знающие люди, пожалуйста.
Поэтому на моей плате появилось столько некрасивых перемычек...
И еще, по схеме чтобы напряжение показывало правильно с нагрузкой и без, пришлось повесить на массу входной контакт токоограничительного сопротивления. Кто как в этой ситуации поступил, а то на самом деле обе схемы в статье отличаются (в одной 2-я нога ОУ заведена на землю, на другой - нет).
И еще, иногда (ну, то есть почти всегда) очень быстро меняются показания напряжения и тока в малом диапазоне (десятые вольта и сотые ампер очень быстро перемениваются, почти сливаются на ЖК экране), трудно понять значения. Помогает убавление напряжения до нуля и плавное поднятие. Вот как то так на данный момент.
P.S. Видимость измерений и правда хуже, чем у LED-сегментов. Приходится ровно на экран смотреть, сбоку видно плоховато. Пока все. Жду комментариев.

И еще, перепрошить этот МК на плате в режиме ISP можно? Или придется какие-то детали выпаивать???

#52
wiktors75

wiktors75

    Новичок

  • Пользователи
  • Pip
  • 1 сообщений

Я собрал сие чудо, и у меня ток-9,99А и не реагирует на регулировку, температура-0,00 без знака Цельсия. В чём может быть проблема? Собрал на МЕГЕ в DIP корпусе. Усилитель тока lm358. К стати вчера заметил разницу в схемах: На одной схеме на 2 ногу Lm358 идёт земля от МЕГИ (22 вывод), а на второй схеме-нет. Почему так?



rotaru,смог ли иправить?(у меня такая же ситуация с током и температурой.

#53
Евгений_3

Евгений_3

    Новичок

  • Пользователи
  • Pip
  • 1 сообщений
  • ГородУхта РК

Вопрос: Собрал данный девайс на Атмеге 8 в DIP корпусе. С прошивкой на напряжение 51 вольт и ток 51 ампер всё работает нормально, а вот с прошивкой на 50 вольт и ток 9,99 ампер по экрану с низу в верх бежит как бы светлая полоска. Если прибавить контрастность, эта полоска пропадает, но зато становятся видимыми чуть тёмные квадратики для знаков. И ещё в данной прошивке температура показывается с запятой и без буквы С. Может кто встречался с такой проблемой? Как это поправить?






Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных