Перейти к содержимому

Фотография

Сapmeter


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 34

#1
Nikolai4

Nikolai4

    Создатель

  • Администраторы
  • 1211 сообщений
статья тут
А Обсуждаем мы тут.

#2
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
не понял куда меня занесло, фьюзы поставил внешний кварц все галки в пони проге убрал т.е. 1111. контраст подключил как по указанной ссылке, просто описывать не стал

#3
zaa-1978

zaa-1978

    Продвинутый пользователь

  • Мастера
  • PipPipPip
  • 255 сообщений
  • ГородХарьков
ну когда подаёш питание что происходит на дисплее. даже лудше включи без микрухи и виставь контрастность чтоб било видно но не сильно темно.

#4
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
zaa-1978, да опыт подключения дисплея есть, просто дальше ноль эмоций.

#5
demadsv5795

demadsv5795

    Пользователь

  • Пользователи
  • PipPip
  • 10 сообщений
А я запустил,дисплей WH1602A-YYK-CTK,пришлось малость исходники подправить,в архиве прошивка,попробуйте,может пойдёт,у меня сначала было видно что дисп инится,и всё,а щас нормально,я правда на макетке пока сделал,потом буду платку разводить.

Прикрепленные файлы

  • Прикрепленный файл  capmeter.rar   3.23К   70 Количество загрузок:
  • Прикрепленный файл  s6961120.jpg   23.26К   71 Количество загрузок:


#6
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
demadsv5795, спасибо, буду проверять. у меня тоже дисплей WH1602A-YYK-CTK.

Добавлено (09.04.2010, 05:37)
---------------------------------------------
demadsv5795, что то нет ничего, возможно косяк на плате. подскажи какие фьюзы установил в 0, а какие в 1, и может дашь схему как дисплей подключил? я шью пони прогом


#7
demadsv5795

demadsv5795

    Пользователь

  • Пользователи
  • PipPip
  • 10 сообщений
Я шил через АВР-Студию,как в понипроге выставлять фузы-я не знаю,никогда его не любил,просто надо выставить на внешний кварц 16 Мгц,а остальные там не важны,опиши что конкретно происходит,сначала появляються верхние квадратики? потом они пропадают?

Добавлено (09.04.2010, 16:13)
---------------------------------------------
А подключил так-же как и ты писал-контроллер/ЛСД - 19-4, 18-6, 17-14,16-13, 15-12, 14-11, минус-5, минус-1, плюс-2, контраст-3


#8
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
demadsv5795, ничего не происходит, квадратики вроде при увеличении контрастности появляются. подозреваю ошибку в монтаже. а через авр студио тоже шил, но потом чтото программатор стал медленно работать

#9
demadsv5795

demadsv5795

    Пользователь

  • Пользователи
  • PipPip
  • 10 сообщений
У меня с самого начала просто появлялась верхняя строка(тест самого диспа),и всё,пришлось искать в исходниках ошибку,менять на мегу8,и уменьшать задержку,тогда только пошло

Добавлено (09.04.2010, 16:23)
---------------------------------------------
так квадратики остаются,не пропадают?ищи на плате ошибки


#10
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
demadsv5795, так у меня кстати мега 8

Добавлено (09.04.2010, 16:49)
---------------------------------------------
demadsv5795, а ты кстати для какого контроллера скидывал файл?


#11
demadsv5795

demadsv5795

    Пользователь

  • Пользователи
  • PipPip
  • 10 сообщений
Для Меги8,так какие у тебя симптомы?

#12
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
включаю, дисплей светится, надписи не появляются.

#13
demadsv5795

demadsv5795

    Пользователь

  • Пользователи
  • PipPip
  • 10 сообщений
как именно включается дисплей?Тестовый сигнал диспа есть?(верхняя строчка) Потом как,пропадает?

#14
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
demadsv5795, извиняюсь, отходил за чаем, сейчас заново скачал выложенную прошивку, дисплей включился. надписи есть показывает 38 пф, светодиод моргает,

#15
demadsv5795

demadsv5795

    Пользователь

  • Пользователи
  • PipPip
  • 10 сообщений
ну вот,не так-уж и страшно,нажми и держи кнопку,пока не появится надпись-калибрате:зеро

Добавлено (09.04.2010, 17:29)
---------------------------------------------
я кстати поставил вместо 1,8 Мом резюк на 1 Мом,по-мойму точнее показует


#16
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
интересно, у меня кондер на 470 мкф, а прказывает 1,121

#17
demadsv5795

demadsv5795

    Пользователь

  • Пользователи
  • PipPip
  • 10 сообщений
ты электролит что-ли меряешь?

#18
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
ну да, или это устройство только для неполярных?

#19
demadsv5795

demadsv5795

    Пользователь

  • Пользователи
  • PipPip
  • 10 сообщений
хотя я щас попробовал элетролиты-меряет

#20
Андрей79

Андрей79

    Пользователь

  • Проверенные
  • PipPip
  • 12 сообщений
ну на рисунках показан что электролит тоже мерит




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных